Close X

News for Mobile Banking Users

News for Mobile Banking Users

Effective June 25 2017, changes are being implemented to keep the security at the highest possible level for Mobile Banking. You will need to be sure that your device is on a compatible OS (Operating System).

Please ensure that you are using a compatible version as listed below.

  • Android users with devices on Android KitKat 4.4-4.4.4 (Level 20) and above will be able to connect to Mobile Banking
  • Iphone users with devices on iOS 8 and above will be able to connect to Mobile Banking

 

If you are on an older version, please upgrade to the compatible Operating System before June 25th to ensure connectivity with Mobile Banking.

If you are not sure how to check which OS you are currently on, follow these instructions or contact the merchant where you purchased your phone if you need assistance determining your OS version or upgrading to a newer OS.

  • Iphones –
    • Open your device settings
    • Tap on General
    • Tap on About
    • The version should be listed on that page
  • Androids
    • Open your device settings
    • Tap on About your phone or About device
    • Tap Andriod Version to display your version information

Also, for security purposes you are required to change your Online Banking password annually.  When it is time for your password to be changed you will receive this message in Mobile Banking – Unable to validate your information.  When you receive this message you will need to log into Online Banking to reset your password and your password will carry through to Mobile Banking.  A reminder will  not be sent ahead of time.

 

If you have any questions or concerns, please contact Online Banking Support at 800-344-7048 ext 3989.

Leave a Reply

Your email address will not be published. Required fields are marked *